<!DOCTYPE html> <html lang="en-US"> <head> <script>var pb_global={pageName:"article-template",pageId:"rHJ9vP1Xz0ktKr",contextPath:"/pb",isAdmin:false,layoutEngineName:"",environment:"prod",resourceToken:"",_website:"kfda"};</script> <script>window.serviceCallbacks=[];window.pageBuilder=window.pageBuilder||{};window.pageBuilder.featureLoaded=function(el){if(window.services.asyncFeatureCallback)window.services.asyncFeatureCallback(el);else window.serviceCallbacks.push(function(){window.services.asyncFeatureCallback(el)})};</script> <script>(function(){if(window.BOOMR&&window.BOOMR.version)return;var dom,doc,where,iframe=document.createElement("iframe"),win=window;function boomerangSaveLoadTime(e){win.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(win.addEventListener)win.addEventListener("load",boomerangSaveLoadTime,false);else if(win.attachEvent)win.attachEvent("onload",boomerangSaveLoadTime);iframe.src="javascript:false";iframe.title="";iframe.role="presentation";(iframe.frameElement||iframe).style.cssText="width:0;height:0;border:0;display:none;";
where=document.getElementsByTagName("script")[0];where.parentNode.insertBefore(iframe,where);try{doc=iframe.contentWindow.document}catch(e){dom=document.domain;iframe.src="javascript:var d\x3ddocument.open();d.domain\x3d'"+dom+"';void(0);";doc=iframe.contentWindow.document}doc.open()._l=function(){var js=this.createElement("script");if(dom)this.domain=dom;js.id="boomr-if-as";js.src="https://c.go-mpulse.net/boomerang/"+"XPXCW-DAMJV-5VCNY-NSGAA-ZZ4G2";BOOMR_lstart=(new Date).getTime();this.body.appendChild(js)};
doc.write('\x3cbody onload\x3d"document._l();"\x3e');doc.close()})();</script> <script>
  const addZeroPad = function(num) {
    num = Math.abs(num)
    num = num.toString()
    if (num.length === 1) {
      num = '0' + num
    }
    return num
  }

  const getTimezoneOffset = function() {
    const offset = -new Date().getTimezoneOffset() / 60
    const sign = offset < 0 ? '-' : '+'
    return sign + addZeroPad(offset) + ':00'
  }
</script> <script>
  var RCdataLayer = [{
    "adTarget": "kfda/web/news",
    "authors": [
                  
                    {
                      "_id": "rbullard",
                      "name": "Richard Bullard",
                      "type": "author"
                    },
                  
                ],
    "canonicalUrl": "/2019/12/25/amarillo-man-dies-vehicle-crash/",
    "contentId": "AZYJIY3VCZHSFAFKYWIONTNOME",
    "contentName": "Amarillo man dies in 3 vehicle crash",
    "contentOwner": "kfda",
    "contentTags":  [
                  
                    {
                      "text": "news",
                      "description": "news",
                      "slug": "news"
                    },
                  
                    {
                      "text": "top story",
                      "description": "top story",
                      "slug": "top-story"
                    },
                  
                    {
                      "text": "events",
                      "description": "events",
                      "slug": "events"
                    },
                  
                ],
    "contentType": "story",
    "datePublished": "2019-12-25T20:30:44.165Z",
    "description": "The Amarillo Police Department responded to a major crash involving three vehicles Tuesday afternoon.",
    "distributorCategory": "staff",
    "distributorMode": "",
    "distributorName": "raycom",
    "distributorReferenceId": "",
    "distributorSubCategory": "",
    "hasVideo": "true",
    "metaDescription": "The Amarillo Police Department responded to a major crash involving three vehicles Tuesday afternoon.",
    "platformName": "Arc Feature Pack",
    "primarySection": 
                        
                        
                          
                          {
                            "name": "News",
                            "_id": "/news",
                            "path": "/news",
                          }
                        
                      ,
    "publishedDay": "25",
    "publishedMonth": "12",
    "publishedYear": "2019",
    "stationName": "kfda",
    "timezoneOffset": getTimezoneOffset(),
    "userAgent": navigator.userAgent,
    "userId": "",
    "userTimezone": Intl.DateTimeFormat().resolvedOptions().timeZone,
    "userTimezoneTimestamp": new Date()
  }]

</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!="dataLayer"?"\x26l\x3d"+l:"";j.async=true;j.src="https://www.googletagmanager.com/gtm.js?id\x3d"+i+dl;f.parentNode.insertBefore(j,f)})(window,document,"script","RCdataLayer","GTM-M5QQ3JP");</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta name="distribution" content="global"/> <meta name="rating" content="general"/> <meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"> <meta charset="UTF-8"/> <meta name="copyright" content="Copyright (c) 2017 "/> <meta name="google-site-verification" content="AM1DpTSjpBbIAVkw5JxUNI4PZqdmxngPVPd_3T6gk8g"/> <title>Amarillo man dies in 3 vehicle crash</title> <meta name="keywords" content="community, APD, Crash Christmas Eve, Amarillo man dies Christmas Eve, Tuesday Crash"> <meta name="news_keywords" content="community, APD, Crash Christmas Eve, Amarillo man dies Christmas Eve, Tuesday Crash"/> <meta name="date" content="2019-12-25T20:46:33.786Z"/> <meta itemprop="description" name="description" content="The Amarillo Police Department responded to a major crash involving three vehicles Tuesday afternoon."/> <meta name="robots" content="index,follow,noarchive"/> <meta name="googlebot" content="index"/> <meta name="googlebot-news" content="index"/> <link rel="canonical" href="https://www.newschannel10.com/2019/12/25/amarillo-man-dies-vehicle-crash/"> <meta name="twitter:title" content="Amarillo man dies in 3 vehicle crash"/> <meta name="twitter:image" content="https://www.newschannel10.com/resizer/kmj9pLEHYujwe6CTI_WllUaVA6M=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/NJAVR6UHUFDJVKSOMPFOPMO36A.PNG"/> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:description" content="The Amarillo Police Department responded to a major crash involving three vehicles Tuesday afternoon."/> <meta name="twitter:site" content="@NewsChannel10"/> <meta name="twitter:creator" content="@NewsChannel10"> <meta property="og:url" content="https://www.newschannel10.com/2019/12/25/amarillo-man-dies-vehicle-crash/"/> <meta property="og:title" content="Amarillo man dies in 3 vehicle crash"/> <meta itemprop="image" property="og:image" content="https://www.newschannel10.com/resizer/kmj9pLEHYujwe6CTI_WllUaVA6M=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/NJAVR6UHUFDJVKSOMPFOPMO36A.PNG"/> <meta property="og:description" content="The Amarillo Police Department responded to a major crash involving three vehicles Tuesday afternoon."/> <meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="https://www.newschannel10.com"/> <meta property="og:type" content="article"/> <meta property="fb:pages" content="121467212293"/> <meta property="fb:admins" content="644426401"/> <meta name="burst" content="KFDA"/> <meta property="article:publisher" content="https://www.facebook.com/NewsChannel10"> <meta property="article:tag" content="news, top story, events"> <link rel="amphtml" href="/2019/12/25/amarillo-man-dies-vehicle-crash/?outputType=amp"> <meta name="author" content="Richard Bullard"> <script data-schema="NewsArticle" type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": ""
        },
        "headline": "Amarillo man dies in 3 vehicle crash",
        
        "image": {
          "@type": "ImageObject",
          "url": "https://www.newschannel10.com/resizer/kmj9pLEHYujwe6CTI_WllUaVA6M=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/NJAVR6UHUFDJVKSOMPFOPMO36A.PNG",
          "height": 481.0,
          "width": 1200
        },
        
        "datePublished": "2019-12-25T20:46:32.316Z",
        "dateModified": "2019-12-25T20:46:33.786Z",
        "articleBody": "AMARILLO, Texas (KFDA) - The Amarillo Police Department responded to a major crash involving three vehicles Tuesday afternoon.According to APD, a Texas DPS trooper witnessed the accident that happened yesterday at around 1:00 p.m.Authorities say a 65-year-old man of Hereford was driving a tractor-trailer westbound on East Amarillo Boulevard.As the Hereford man turned south onto Ridgemere St, he turned in front of a 2006 Lincoln driven by 53-year-old Freddy Buckingham of Amarillo, going eastbound.Buckingham struck the rear of the trailer, lost control and spun into westbound traffic before it hit a black 2018 Chevy Camaro driven by a 49-year-old woman of Amarillo.He was taken to an area hospital where he later died from his injuries.The woman suffered non-life threatening injuries. The semi driver was uninjured.Authorities believe speed and no seat-belt use were factors in the crash.The incident is being investigated by the Traffic Investigation Squad of the Amarillo Police Department.Copyright 2019 KFDA. All rights reserved.",
        "author": [
          
            
              
                {
                  "@type": "Person",
                  "name": "Richard Bullard"
                }
              
            
            
          
        ],
         "publisher": {
        "@type": "Organization",
        "name": "KFDA",
        "logo": {
          "@type": "ImageObject",
          "url": "https://www.newschannel10.com/pb/resources/images/rm_icons/kfda-icon.png?token=123",
          "width": 467,
          "height": 60
        }
      }
        },
        // will be empty for branded publishing
        "description": "The Amarillo Police Department responded to a major crash involving three vehicles Tuesday afternoon."
      }
    </script> <script data-schema="Organization" type="application/ld+json">
      {
        "name": "KFDA",
        "url": "https://www.newschannel10.com",
        "logo": "https://www.newschannel10.com/pb/resources/images/rm_icons/kfda-icon.png?token=123",
        "@type": "Organization",
        
          "sameAs": [ "https://www.facebook.com/NewsChannel10" ],
        
        "@context": "http://schema.org"
      }
    </script> <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous"> <link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css"> <link href="https://fonts.googleapis.com/css?family=Oswald:400,600,700|PT+Serif:400,400i,700i" rel="stylesheet"> <link href="/pb/resources/dist/5e5227607d47902091f9/rm/rm-framework5e5227607d47902091f9.css?v=84" rel="stylesheet"/> <style>.logo{background-image:url(/pb/resources/images/kfda-logo.svg?v=84)}.logo.logo-footer{background-image:url(/pb/resources/images/footer_icons/kfda-logo.svg?v=84)}</style> <link href="/pb/resources/dist/5e5227607d47902091f9/rm/rm-framework5e5227607d47902091f9.css?v=84" rel="stylesheet"/> <link href="/pb/resources/dist/5e5227607d47902091f9/rm/rm-features5e5227607d47902091f9.css?v=84" rel="stylesheet"/> <link href="/pb/resources/dist/5e5227607d47902091f9/rm/rm-services5e5227607d47902091f9.css?v=84" rel="stylesheet"/> <script src="/pb/gr/c/default/rHJ9vP1Xz0ktKr/arcAdsJS/cdbd7d78da.js?v=84"></script> <script>
  const arcAds = new ArcAds({
    dfp: {
      id: '63316753'
    }
  });
  window.arcAds = arcAds;
</script> <script src="//cdn.connatix.com/min/connatix.renderer.infeed.min.js" data-connatix-token="8d5ed4b9-4109-440b-9262-b393e0b5d952" async></script> </head> <body> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> </head> <body> <div id="pb-root" class=""><a class="skip-link" href="#header">Skip to content</a> <section id="nav" class="relative zindex-higher col"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-sales-nav" id="faYVSr1Xz0ktKr"> <div id="sales-nav" class="background-grey-minimal visible-lg"> <div class="container"> <ul class="list-unstyled flex-container-row padded padded-top padded-bottom padded-xs"> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.newschannel10.com/business/expert-connections/" class="color-grey-dark">Expert Connections</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.newschannel10.com/health/health-connections/" class="color-grey-dark">Health Connections</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.newschannel10.com/contests/" class="color-grey-dark">Contests</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.newschannel10.com/community/moms-talk/" class="color-grey-dark">Moms Talk</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.newschannel10.com/babyboomerstalk/" class="color-grey-dark">Baby Boomers Talk</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://panhandledeals.revrocket.us/n/#!/home" class="color-grey-dark">Panhandle Deals</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.newschannel10.com/community/viewers-choice-awards/" class="color-grey-dark">Viewers Choice Awards</a></li> </ul> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" id="f0aKfloXz0ktKr"> <style>.pb-f-article-body .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 200px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}.pb-f-article-body .card .img-container.width-full,.pb-f-article-header .card .img-container.width-full{background-color:#f9f9f9}.pb-f-article-header .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 150px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}</style> </div> <div class="pb-container"> </div> </section> <header id="sticky-nav" class="sticky zindex-higher col"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-navigation-bar" id="f0ExsO8Xz0ktKr"> <div id="app-bar" class="app-bar card padded padded-sm padded-top padded-bottom width-full" role="navigation"> <div class="justify-space-between align-items-center flex-container-row relative app-bar-inner container"> <button id="app-bar-topics-button" name="topicsMenu" class="app-button justify-center flex-container-row no-border" data-role="open-tray" data-tray="topics"> <span class="fa fa-2x fa-bars" aria-hidden="true"></span> </button> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.newschannel10.com"> <div class="logo logo-slim"></div> </a> </div> <div class="app-bar-top-container flex-3 flex-container-row relative spaced spaced-sm spaced-left spaced-right hidden-sm"> <ul id="app-bar-top-menu" class="list-unstyled flex-container-row topics-list uppercase align-items-center flex-shrink"> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/homepage" class="">Home</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news" class="">News</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather" class="">Weather</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather/closings" class="">Closings</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather/firstalert" class="">First Alert</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/sports" class="">Sports</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/community" class="">Community</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/panhandle-magazine" class="">Panhandle Magazine</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/about-us" class="">About Us</a> </h3> </li> </ul> </div> <div class="search-box-container search-box flex flex-container-row align-items-center justify-end"> <div class="search-box-inner"> <form class="search search-expandable-form small" action="/search/" method="GET"> <input type="checkbox" class="checkbox" name="search-action" id="search-action"/> <label class="magnifying-glass" for="search-action"> <i class="search-button fa fa-search"></i> <i class="close-button fa fa-times"></i> </label> <input type="text" class="search-text-field" id="expandable-search" name="q" placeholder="Search..."/> </form> </div> </div> </div> </div> <div class="app-bar-tray" data-role="tray" data-tray="topics"> <nav [class]="visible == true ? 'tray left-0 hidden width-full zindex-high tray-open visible' : 'tray left-0 hidden width-full zindex-high hidden'" class="tray left-0 hidden width-full zindex-high"> <div class="topics-tray tray-contents card card-dark padded padded-bottom padded-md"> <div class="tray-contents-inner container" tabindex="0"> <div class="five-hundred-screen-height"> <div class="container"> <div class="flex-grid"> <div class="tray-section tray-section-1 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/homepage" class="color-white">Home</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="https://www.newschannel10.com/apps/" class="color-white">Download our Apps</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="http://www.newschannel10.com/live" class="color-white">WATCH LIVE</a> </div> </div> </div> </div> <div class="tray-section tray-section-2 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/panhandle-magazine" class="color-white">Panhandle Magazine</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="https://www.newschannel10.com/panhandle-magazine/fall-2019/" class="color-white">FALL 2019</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://www.newschannel10.com/panhandle-magazine/winter-2019/" class="color-white">Winter 2019</a> </div> </div> </div> </div> <div class="tray-section tray-section-3 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/about-us" class="color-white">About Us</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="https://www.newschannel10.com/2019/12/20/click-here-current-job-openings-newschannel/" class="color-white">Jobs at NewsChannel 10</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://www.newschannel10.com/2018/09/18/contact-newschannel/" class="color-white">Contact Us</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://www.facebook.com/mundoamarillo12/" class="color-white">Mundo Amarillo</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="http://www.telemundoamarillo.com/" class="color-white">Telemundo Amarillo</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="https://gray.tv/" class="color-white">Gray TV</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="http://www.metv.com/schedule/" class="color-white">MeTV Amarillo</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="https://www.zazzle.com/store/newschannel10_gear" class="color-white">NewsChannel 10 Gear</a> </div> </div> </div> </div> <div class="tray-section tray-section-4 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/weather" class="color-white">Weather</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/weather/firstalert" class="color-white">First Alert</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/weather/closings" class="color-white">Closings</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/weather/cams" class="color-white">Cams</a> </div> </div> </div> </div> <div class="tray-section tray-section-5 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/news" class="color-white">News</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/news/national" class="color-white">National</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/news/crime" class="color-white">Crime</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/news/education" class="color-white">Education</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/news/editorial" class="color-white">Perspective with Brent McClure</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/news/good-news" class="color-white">Good News With Doppler Dave</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/news/above-and-beyond" class="color-white">Above and Beyond</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="/news/through-the-smoke" class="color-white">Through the Smoke</a> </div> </div> </div> </div> <div class="tray-section tray-section-6 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/community" class="color-white">Community</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/community/together-we-can" class="color-white">Together We Can</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://www.newschannel10.com/community/user-content/" class="color-white">Send us your pictures & video</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/community/summer-celebration" class="color-white">Summer Celebration</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/community/community-interviews" class="color-white">Community Interviews</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/community/new-in-amarillo" class="color-white">New in Amarillo</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/community/calendar" class="color-white">Calendar</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="/community/events" class="color-white">Events</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="https://www.newschannel10.com/business/expert-connections/" class="color-white">Expert Connections</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-11"> <a href="/health/health-connections" class="color-white">Health Connections</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-12"> <a href="/community/moms-talk" class="color-white">Moms Talk</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-13"> <a href="https://www.newschannel10.com/babyboomerstalk/" class="color-white">Baby Boomers Talk</a> </div> </div> </div> </div> <div class="tray-section tray-section-7 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/sports" class="color-white">Sports</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/sports/amarillo-baseball" class="color-white">Amarillo Baseball</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/sports/amarillo-bulls" class="color-white">Amarillo Bulls</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/sports/amarillobombers" class="color-white">Amarillo Bombers</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/sports/amarillo-venom" class="color-white">Amarillo Venom</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/sports/high-school/basketball" class="color-white">Hoops Madness</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/sports/high-school/football" class="color-white">The Wrap Up</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="/sports/ncaa/wtamu" class="color-white">WTAMU</a> </div> </div> </div> </div> <div class="tray-section tray-section-8 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/traffic" class="color-white">Traffic</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/traffic/gas-prices" class="color-white">Gas Prices</a> </div> </div> </div> </div> <div class="tray-section tray-section-9 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/programming" class="color-white">Programming</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/programming/schedule" class="color-white">Programming Schedule</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/programming/second-cup" class="color-white">2nd Cup</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://www.fullcourtgreta.com/" class="color-white">Full Court Press with Greta Van Susteren</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="http://www.circleallaccess.com" class="color-white">Circle - Country Music & Lifestyle</a> </div> </div> </div> </div> <div class="tray-section tray-section-10 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/contests" class="color-white">Contests</a> </h3> </div> </div> <div class="tray-section tray-section-11 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/food/mr-food" class="color-white">Mr. Food</a> </h3> </div> </div> </div> </div> </div> </div> </div> </nav> </div> </div> </div> </header> <section id="top" class="width-full"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-breaking-news" id="f0MEpCZXz0ktKr"> <div id="breaking-news-wrapper" class="breaking-news-wrapper" data-feature-name="breaking-news-bar" data-feature-grouping=".pb-f-global-breaking-news" data-page-uri="/fragment-kfda-breaking/" data-url="/pb/api/v2/render/feature" data-website="kfda" data-view-unpublished=""> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-weather-weather-alerts" id="fZgFpz1Xz0ktKr"> <div id="weather-alerts-wrapper" class="weather-alerts-wrapper" data-feature-name="weather-alerts-bar" data-feature-grouping=".pb-f-weather-weather-alerts" data-page-uri="/kfda-weather-alerts/" data-url="/pb/api/v2/render/feature" data-website="kfda"> <div data-href="/pb/api/v2/render/feature"> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fOcnHR1Xz0ktKr"> <div id="ad1841-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1841" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1841",slotName:"kfda/web/news",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"AZYJIY3VCZHSFAFKYWIONTNOME"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> </div> </section> <div class="container flex-grid"> <article id="content-well" class="col desktop-8 tablet-12 mobile-12"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-article-header" id="f0G8x4vXz0ktKr"> <div class="card spaced card-article width-full spaced-bottom spaced-xs"> <div class="text-align-left card-content"> <ul class="tag-list-wrapper list-unstyled flex-container-row text-align-left uppercase unstyled-link spaced spaced-top spaced-sm call-to-action bold"> <li class=""> <a class="tag unstyled-link call-to-action uppercase bold unstyled-link tag-first" href="https://www.newschannel10.com/news"> News </a> </li> </ul> <h1 class="spaced spaced-xs spaced-top spaced-bottom">Amarillo man dies in 3 vehicle crash</h1> <h2 class="spaced spaced-xs spaced-top"></h2> </div> <div class="spaced spaced-top spaced-sm"> <div class="card-content"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-article-goldfish-video" id=""> <div class="video"> <div class="goldfish-video" data-video-id="powa-72-5ac6986b-5ba2-48f9-967b-b368453cf2c5" data-script-path="d3mo2m0b34ee8e" data-environment="prod"></div> <div class="goldfish-player" data-page-on="1" data-producer=""> <div class="powa" id="powa-72-5ac6986b-5ba2-48f9-967b-b368453cf2c5" data-ping-rate="15" data-org="raycom" data-uuid="5ac6986b-5ba2-48f9-967b-b368453cf2c5" data-playthrough="true" data-sticky="true" data-autoplay="true"></div> </div> <figcaption class="caption-text spaced spaced-top spaced-xs flex-container-row justify-space-between"> <div>Video - Amarillo man dies in 3 vehicle crash - KFDA</div> </figcaption> </div> </div> </div> </div> </div> </div> <div class="flex-grid flex-container-row flex-mobile-column col col-no-side-gutter pb-layout-item pb-chain pb-c-article-double-chain full" id="c0qBKcXXz0ktKr"> <section id="article-sharebar" class="col col-no-gutter desktop-1 visible-lg spaced spaced-top spaced-sm"> <div class="flex flex-container-row sticky"> <span class="sharebar app-bar-share sharebar flex-container-column text-align-right"> <button class="social-icon spaced spaced-top spaced-sm" aria-label="share on twitter" name="twitter" onclick="window.open( 'https://twitter.com/intent/tweet?text=Amarillo+man+dies+in+3+vehicle+crash&amp;url=https%3A%2F%2Fwww.newschannel10.com%2F2019%2F12%2F25%2Famarillo-man-dies-vehicle-crash%2F', 'share_popup', 'height=500,width=650' ); return false;" role="button" data-arctrack="socialShareTwtr" data-referrer="" target="_blank" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="fab fa-twitter social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> <button class="social-icon spaced spaced-top spaced-sm" name="facebook" aria-label="share on facebook" onclick="window.open( 'https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.newschannel10.com%2F2019%2F12%2F25%2Famarillo-man-dies-vehicle-crash%2F&amp;title=Amarillo+man+dies+in+3+vehicle+crash', 'share_popup', 'height=500,width=650' ); return false;" data-arctrack="socialShareFb" data-referrer="" target="_blank" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="fab fa-facebook-f social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> <a href="mailto:?subject=Amarillo%20man%20dies%20in%203%20vehicle%20crash&amp;body=Read%20more%20on%20Amarillo%20man%20dies%20in%203%20vehicle%20crash%20at%20https%3A%2F%2Fwww.newschannel10.com%2F2019%2F12%2F25%2Famarillo-man-dies-vehicle-crash%2F"> <button class="social-icon spaced spaced-top spaced-sm" role="button" aria-label="share story via email" data-arctrack="socialShareEmail" data-referrer="" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="far fa-envelope social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> </a> </span> </div> </section> <section class="col col-no-gutter desktop-11 tablet-12 mobile-12 spaced spaced-top spaced-sm"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-byline" id="f0z3yJ5Xz0ktKr"> <div class="card"> <div class="byline spaced spaced-bottom spaced-md card-content display-inline"> By <a class="color-blue hover-link" href="/authors/rbullard/"> <span class="font-bold ">Richard Bullard</span></a> <span class="font-bold">|</span> <span class="timestamp"> December 25, 2019 at 2:30 PM CST - Updated December 25 at 2:46 PM </span> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-body" id="f0OiAz6Xz0ktKr"> <div class="collection collection-cards" id="article-body"> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>AMARILLO, Texas (KFDA) - The Amarillo Police Department responded to a major crash involving <a href="https://www.newschannel10.com/2019/12/24/apd-investigating-major-crash-near-amarillo-boulevard-ridgemere-marrs-street/">three vehicles Tuesday afternoon.</a></p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>According to APD, a Texas DPS trooper witnessed the accident that happened yesterday at around 1:00 p.m.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Authorities say a 65-year-old man of Hereford was driving a tractor-trailer westbound on East Amarillo Boulevard.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>As the Hereford man turned south onto Ridgemere St, he turned in front of a 2006 Lincoln driven by 53-year-old Freddy Buckingham of Amarillo, going eastbound.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad1713-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1713" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1713",slotName:"kfda/web/news/AZYJIY3VCZHSFAFKYWIONTNOME",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Buckingham struck the rear of the trailer, lost control and spun into westbound traffic before it hit a black 2018 Chevy Camaro driven by a 49-year-old woman of Amarillo.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>He was taken to an area hospital where he later died from his injuries.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>The woman suffered non-life threatening injuries. The semi driver was uninjured.</p> <div class="flex-container-column align-items-center hidden-sm spaced spaced-top spaced-sm"> <div id="ad390-sticky" class="flex-container-column "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad390" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad390",slotName:"kfda/web/news/AZYJIY3VCZHSFAFKYWIONTNOME",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Authorities believe speed and no seat-belt use were factors in the crash.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad518-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad518" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad518",slotName:"kfda/web/news/AZYJIY3VCZHSFAFKYWIONTNOME",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>The incident is being investigated by the Traffic Investigation Squad of the Amarillo Police Department.</p> </div> </div> <div data-type="text" class="card collection-item card-border-bottom card-border-bottom-thick card-border-bottom-dark"> <div class="card-content card-article"> <p><i>Copyright 2019 KFDA. All rights reserved.</i></p> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-connatix" id="fwaAKx1Xz0ktKr"> <div class="flex-grid ad-connatix spaced spaced-lg spaced-top spaced-bottom "> <div class="col desktop-12 tablet-12 mobile-12"> <div id="connatix-highlights-embed" class="connatix-container box-shadow-light"></div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-outbrain" id="f06efnJXz0ktKr"> <div id="outbrain-article-ad" class=""> <div class="OUTBRAIN" data-widget-id="AR_8" data-src="https://www.newschannel10.com/2019/12/25/amarillo-man-dies-vehicle-crash/" data-ob-template="raycom"> </div> <div class="OUTBRAIN" data-widget-id="AR_9" data-src="https://www.newschannel10.com/2019/12/25/amarillo-man-dies-vehicle-crash/" data-ob-template="raycom"> </div> </div> </div> </section> </div> <div class="pb-container"> </div> </article> <aside id="right-rail" class="col desktop-4 tablet-12 mobile-12 right-rail"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-ads-arcads tablet-6 mobile-12 desktop-12" id="fzMDJM1Xz0ktKr"> <div id="ad1288-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1288" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1288",slotName:"kfda/web/news",adType:"flex-cube",dimensions:"[[[300, 600], [300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"AZYJIY3VCZHSFAFKYWIONTNOME"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-6 mobile-12 pb-feature pb-layout-item pb-f-weather-forecast-box" id="f47aum1Xz0ktKr"> <div class="invisible weather-gradient flex-grid color-white pb-weather day" id="weather-forecast-box" data-valid-content="true"> <div id="forecast-box-bg-wrapper" data-current-bg-image="day-clear" data-default-location-code="USTX0029" class="weather-item flex pb-weather pb-forecast-box padded padded-md padded-top padded-bottom padded-right padded-left"> <div id="forecast-box-content"> <input type="hidden" id="forecast-box-zip-code" data-url="/pb/api/v2/render/feature/weather/forecast-box" data-feature-grouping=".pb-f-weather-forecast-box" data-website="kfda" data-location-code="USTX0029" data-language="en" data-content-config-keys='Code,Language' data-content-config-values='USTX0029,en' data-custom-field-keys='spanish' data-custom-field-values=''/> <div class="col spaced spaced-top spaced-sm"> <div class="flex-container-row justify-center"> <div class="spaced spaced-right spaced-lg flex-container-row align-items-center"> <a href="https://www.newschannel10.com/weather"> <img class="radar-image" src="//webpubcontent.raycommedia.com/kfda/ottradar.png" width="100%"/> </a> </div> <div class="flex-container-column"> <div class="flex-container-row"> <div class="font-bold temp temp-lg weather-temp temp-lg-forecast-box" data-temp-f="61" data-temp-c="16"> 61</div> <div class="icon spaced spaced-left spaced-md flex-container-row align-items-center"> <img width="40px" height="40px" src="/pb/resources/images/weather/weather-condition-icons/400x400/85_daily_forecast.png" alt="weather icon"/> </div> </div> <div class="spaced spaced-sm spaced-top text-align-center"> <div class="flex-container-column relative"> <div class="text-align-center"> <span class="location font-bold"> Currently in<br/>Amarillo, TX</span> </div> </div> </div> <div class="flex-container-row spaced spaced-top spaced-md justify-center"> <a href="https://www.newschannel10.com/weather"> <button class="weather uppercase button button-mini-radius button-transparent button-white-border color-white bold font-sm padded padded-xs padded-left padded-right padded-top padded-bottom"> Full Forecast</button> </a> </div> </div> </div> </div> </div> <div class="flex-container-row justify-center spaced spaced-md spaced-bottom spaced-top font-semi-bold"> <span class="spaced spaced-right spaced-sm">Sponsored By</span> <div id="ad989-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad989" class="arcad ad-120x30"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad989",slotName:"kfda/web/weather-widget",adType:"weather-sponsorship",dimensions:"[[[120, 30]], [[120, 30]], [[120, 30]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"weather",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:false,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-12 mobile-12 pb-feature pb-layout-item pb-f-article-author-bio" id="frRRQ42Xz0ktKr"> <div class="article-author-bio"> <div class="article-author-bio flex-grid flex-feature"> <h3 class="bold uppercase"> <span class="rectangle"></span> Author </h3> <div class="col desktop-12 tablet-6 mobile-12 height-full"> <div class="card skin"> <div class="card-media"> <div class="flex-grid"> <div class="flex-container-row "> <div class="flex spaced card-media flex-container-column justify-center flex-reverse spaced-left spaced-md"> <div data-type="image" class="author-bio author-bio-image card"> <figure class=""> <div class=" img-container aspect-ratio-3x2"> <img class="b-lazy width-full img-container" alt="Richard Bullard" data-src="https://www.newschannel10.com/resizer/cvA4vVzFFlcjjoWxYuo9YLddfbo=/1400x0/s3.amazonaws.com/arc-authors/raycom/93733f9a-1687-4330-94e4-21a2f98931b1.png" src="https://www.newschannel10.com/resizer/Z7fVwW2PgNMGB9SpqID9LqY8Nf0=/0x10/s3.amazonaws.com/arc-authors/raycom/93733f9a-1687-4330-94e4-21a2f98931b1.png"/> </div> </figure> </div> </div> <div class="flex-2 flex-container-column justify-center"> <a class="spaced spaced-sm spaced-bottom" href="/authors/rbullard/"> <h3 class="promo-header">Richard Bullard</h3> </a> <h4 class="spaced spaced-xs spaced-bottom font-normal color-grey-dark">Digital Content Producer at KFDA </h4> <h4 class="hidden font-normal color-grey-dark"></h4> <span class="buttonbar buttonbar app-bar-share flex-container-grid width-full spaced spaced-sm spaced-top font-lg"> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" aria-label="Contact via email" href="mailto:rbullard@newschannel10.com?subject=Amarillo%20man%20dies%20in%203%20vehicle%20crash&body=" role="button" rel="noopener noreferrer" data-arctrack="socialFollowEm"> <i class="far fa-envelope"></i> </a> </span> </div> </div> <div class="flex-container-row justify-space-between "> <div class="author-bio author-bio-description collection collection-cards"> <div data-type="text" class="card collection-item"> <div class="card-content card-article"> <p class="font-md ">Richard is a digital content producer at NewsChannel 10.</p> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-mailchimp-signup" id="fxwHfN1Xz0ktKr"> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c0NRdx1Xz0ktKr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fhr3sb2Xz0ktKr"> <div class="flex-feature "> <h3 class="bold"><span class="rectangle"></span> RECENT CONTENT</h3> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-64852" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2019/12/25/updates-new-traffic-management-system-amarillo/"> <img class="width-full " alt="Updates on new traffic management system in Amarillo" src="https://www.newschannel10.com/resizer/lmzYb-tzfIeHbznSNgbtfat08Y8=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/W25RSI4AWVENXDUBAKAEJX2JUM.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/12/25/updates-new-traffic-management-system-amarillo/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; Updates on new traffic management system in Amarillo</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">The city officials say they are in the third phase of installing a brand new traffic management system, which will serve the purpose of better improving the flow of traffic in the city.</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>Courtney Tate</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2019/12/25/traffic-back-normal-us-after-two-vehicles-crash-today/"> <img class="width-full " alt="Traffic back to normal on U.S. after two vehicles crash today" src="https://www.newschannel10.com/resizer/_shlRZFcwjEXjHVc1AQH0vyOKvw=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/2APDT7KHSBHLTDOKJ44JVCA3YI.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/12/25/traffic-back-normal-us-after-two-vehicles-crash-today/"> Traffic back to normal on U.S. after two vehicles crash today</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">Traffic on U.S.-87 is now back to normal after a wreck blocked one side of the road earlier today.</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f09JMK9Xz0ktKr"> <div id="ad1717-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1717" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1717",slotName:"kfda/web/news",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"AZYJIY3VCZHSFAFKYWIONTNOME"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c008fu9Xz0ktKr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fmrOMh1Xz0ktKr"> <div class="flex-feature "> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-127776" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/12/25/city-amarillos-thompson-park-pool-update/"> <img class="width-full " alt="City of Amarillo’s Thompson Park Pool update" src="https://www.newschannel10.com/resizer/b6CnnIewE8CpX9Dz7YkhDF2RBK8=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/BZNBKCLVI5APVPQVVF5WQA744Q.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/12/25/city-amarillos-thompson-park-pool-update/"> City of Amarillo’s Thompson Park Pool update</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published December 24, 2019 at 9:22 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/12/24/apd-investigating-major-crash-near-amarillo-boulevard-ridgemere-marrs-street/"> <img class="width-full " alt="APD investigating major crash near Amarillo Boulevard, Ridgemere and Marrs street " src="https://www.newschannel10.com/resizer/gUWtG7Tk_fi0LoT-5MLudKueMGY=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/NJAVR6UHUFDJVKSOMPFOPMO36A.PNG"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/12/24/apd-investigating-major-crash-near-amarillo-boulevard-ridgemere-marrs-street/"> APD investigating major crash near Amarillo Boulevard, Ridgemere and Marrs street </a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>Richard Bullard</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published December 24, 2019 at 3:02 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/12/24/behind-bars-police-arrest-grinch-before-he-can-steal-christmas-joy/"> <img class="width-full " alt="BEHIND BARS: Police arrest the Grinch before he can steal Christmas joy" src="https://www.newschannel10.com/resizer/Rbub0CndhZ_Mqio9szLN4Z4jmxo=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/O5PVKVBPRNHQHAJ6AJKCXPSJEA.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/12/24/behind-bars-police-arrest-grinch-before-he-can-steal-christmas-joy/"> BEHIND BARS: Police arrest the Grinch before he can steal Christmas joy</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Lindsay Knowles</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published December 24, 2019 at 10:54 AM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/12/24/police-investigating-vehicle-vs-pedestrian-amarillo-boulevard-christmas-eve/"> <img class="width-full " alt="1 struck by vehicle, sent to the hospital with life-threatening injuries on Amarillo Boulevard this Christmas Eve" src="https://www.newschannel10.com/resizer/XSDJ6WAnTPRq2vAL8tS3Un31Ww8=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/USTJVGORNZDYDNRN3JZGA2HLEU.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/12/24/police-investigating-vehicle-vs-pedestrian-amarillo-boulevard-christmas-eve/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; 1 struck by vehicle, sent to the hospital with life-threatening injuries on Amarillo Boulevard this Christmas Eve</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>Vanessa Garcia</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published December 24, 2019 at 7:48 AM </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="pb-container"> </div> </aside> <div id="recirc" class="col desktop-12 tablet-12 mobile-12"> </div> </div> <section id="bottom" class="col desktop-12 tablet-12 mobile-12"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f0XShVkXz0ktKr"> <div id="ad1816-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1816" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1816",slotName:"kfda/web/news",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"AZYJIY3VCZHSFAFKYWIONTNOME"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-footer" id="fU2oFF1Xz0ktKr"> <footer class="card card-dark"> <div class="container"> <div class="container spaced spaced-sm spaced-left"> <div class="flex flex-container-column flex-tablet-row flex-desktop-row width-full color-white"> <div class="spaced spaced-right spaced-bottom spaced-xl"> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.newschannel10.com"> <div class="logo logo-large logo-footer"></div> </a> </div> </div> <div class="spaced spaced-right spaced-xl footer-mission"> <p class="spaced spaced-bottom spaced-xs"> 7900 Broadway<br/>Amarillo, TX 79105<br/>(806) 383-1010 </p> <a class="call-to-action uppercase color-white" href="http://www.newschannel10.com/about-us">Contact Us <i class="fa fa-caret-right" aria-hidden="true"></i></a> <div class="spaced spaced-top spaced-xl hidden-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="https://www.facebook.com/mundoamarillo12/" class="color-white">Mundo Amarillo</a></li> <li><a href="http://www.metv.com/schedule/" class="color-white">MeTV Amarillo</a></li> <li><a href="http://www.telemundoamarillo.com/" class="color-white">Telemundo Amarillo</a></li> <li><a href="http://publicfiles.fcc.gov/tv-profile/kfda-tv" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@kfda.com" class="color-white">publicfile@kfda.com<br/>(806) 383-1010</a></li> <li><a href="http://webpubcontent.raycommedia.com/kfda/2019EEO.pdf" class="color-white">EEO REPORT</a></li> <li><a href="http://www.newschannel10.com/story/30586832/close-caption-information/" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">KFDA Careers</a></li> <li><a href="/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="/terms-of-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="spaced spaced-top spaced-xl hidden-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/NewsChannel10" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/NewsChannel10" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> <div class="spaced spaced-right spaced-xl visible-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="https://www.facebook.com/mundoamarillo12/" class="color-white">Mundo Amarillo</a></li> <li><a href="http://www.metv.com/schedule/" class="color-white">MeTV Amarillo</a></li> <li><a href="http://www.telemundoamarillo.com/" class="color-white">Telemundo Amarillo</a></li> <li><a href="http://publicfiles.fcc.gov/tv-profile/kfda-tv" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@kfda.com" class="color-white">publicfile@kfda.com<br/>(806) 383-1010</a></li> <li><a href="http://webpubcontent.raycommedia.com/kfda/2019EEO.pdf" class="color-white">EEO REPORT</a></li> <li><a href="http://www.newschannel10.com/story/30586832/close-caption-information/" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">KFDA Careers</a></li> <li><a href="/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="/terms-of-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="visible-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/NewsChannel10" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/NewsChannel10" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> </div> </div> </footer> </div> <div class="pb-container"> </div> </section> </div> <script async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <script async src='/pb/gr/p/default/rHJ9vP1Xz0ktKr/render.js?v=84'></script> <script>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</script> <script>window.banditoEnv={TIMEOUT:1500,PERF_API:"https://bandito-events.perso.aws.arc.pub/api/save-perf",TESTS_API:"https://bandito.perso.aws.arc.pub/api/variants",EVENTS_API:"https://bandito-events.perso.aws.arc.pub/api/save-event"};if(window["pageBuilder"]&&window["pageBuilder"]["initVariants"])window.pageBuilder.initVariants({IS_ADMIN:false,TIMEOUT:window.banditoEnv.TIMEOUT,PERF_API:window.banditoEnv.PERF_API,TESTS_API:window.banditoEnv.TESTS_API,EVENTS_API:window.banditoEnv.EVENTS_API});</script> <script async src="/pb/resources/dist/5e5227607d47902091f9/rm/rm-index5e5227607d47902091f9.js"></script>